Скрипт обновления клиента под Linux

Для работы нужно установить следующие перловые модули:

1) LWP::UserAgent, либо чтобы в системе была установлена утилита wget
2) Digest::MD5, либо чтобы в системе была установлена утилита md5sum
3) Compress::Raw::Zlib
4) Compress::Bzip2, либо чтобы в системе была установлена утилита bzip2
5) Если вместо перловых модулей (при их отсутствии) используется хотя-бы одна из утилит md5sum или bzip2, то требуется наличие модуля IPC::Open2

Чаще всего в системе уже установлены все необходимые утилиты, которые могут заменить ряд перловых модулей (wget, md5sum, bzip2). Остаётся только установить Compress::Raw::Zlib (если он не установлен).

Как это сделать:
1) Если у вас Gentoo, выполняете команду: emerge dev-perl/Compress-Raw-Zlib
2) Если у вас RedHat-подобная система (Suse, Mandriva, Fedora, etc...), то есть система в которой используются пакеты rpm, значит необходимый пакет называется perl-Compress-Raw-Zlib
3) Если у вас Debian-подобная система (Debian, Ubuntu, etc...), то есть система, в которой используются пакеты deb, в этом случае пакет называется libcompress-raw-zlib-perl

Скачать скрипт